Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > Visual C++ MFC > Report Control
  New Posts New Posts RSS Feed - BUG: Icon displacement when using XAML
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

BUG: Icon displacement when using XAML

 Post Reply Post Reply
Author
Message
mgampi View Drop Down
Senior Member
Senior Member
Avatar

Joined: 14 July 2003
Status: Offline
Points: 1072
Post Options Post Options   Thanks (0) Thanks(0)   Quote mgampi Quote  Post ReplyReply Direct Link To This Post Topic: BUG: Icon displacement when using XAML
    Posted: 23 May 2017 at 2:51am
Hi:

I'm using the report control as a tree with only one column. Item descriptions are XAML based.
When you take a look at the screenshot attached you can see that icons of records with children are placed with an offset of 2 or 3 pixels to the right of records with no children. I've marked the offset in the screenshot below with red vertical lines:



The XAML I use:

<WrapPanel TextBlock.FontFamily = 'Tahoma' TextBlock.FontSize = '8.25pt' TextBlock.FontQuality = 'ClearType' TextBlock.Foreground = '#000000'>
<TextBlock Margin = '5,0,0,0'>HERE IS THE ITEM DESCRIPTION</TextBlock></WrapPanel>


How can I fix this (using v.17.3.0).
Martin

Product: Xtreme Toolkit v 15.3.1, new Projects v 18.5.0
Platform: Windows 8.1 (64bit)
Language: VC+
Back to Top
mgampi View Drop Down
Senior Member
Senior Member
Avatar

Joined: 14 July 2003
Status: Offline
Points: 1072
Post Options Post Options   Thanks (0) Thanks(0)   Quote mgampi Quote  Post ReplyReply Direct Link To This Post Posted: 12 March 2019 at 11:15am
Any news regarding this problem? I can still see it in 18.6.
Martin

Product: Xtreme Toolkit v 15.3.1, new Projects v 18.5.0
Platform: Windows 8.1 (64bit)
Language: VC+
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.110 seconds.