Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > ActiveX COM > Task Panel
  New Posts New Posts RSS Feed - using Officexxxx.dll for Taskbar VisualTheme
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

using Officexxxx.dll for Taskbar VisualTheme

 Post Reply Post Reply
Author
Message
Hawk78 View Drop Down
Groupie
Groupie


Joined: 20 November 2012
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hawk78 Quote  Post ReplyReply Direct Link To This Post Topic: using Officexxxx.dll for Taskbar VisualTheme
    Posted: 27 June 2013 at 10:15am
Hi,
 
I'm using VB 6 and Controls v15.3.1 (Active X) For my TaskPanel I set at design time:
 
wndTaskPanel.VisualTheme = xtpTaskPanelThemeOffice2003
 
When I compile my program an run it on a different pc, the Office2003 Theme disappeard.
I guess that I need to load a Theme from a ressource dll, but I'm not sure how to do.
 
1)  I can only see Office2007.dll, Office2010.dll and Windows7.dll but no Office2003.dll. Where can i get this?
 
2) Is ist correct to load a Visual theme like this? 
Call TaskPanelGlobalSettings.ResourceImages.LoadFromFile(App.Path & "\Office2010.dll", Office2010Blue.ini")
 wndTaskPanel.VisualTheme = xtpTaskPanelThemeResource
 
The helpfile shows:
 
'*** Task Panel ***

'Set Task Panel to Office 2007 Black
TaskPanelGlobalSettings.ResourceThemeImages.LoadFromFile App.Path & "\..\..\..\Styles\Office2007.dll,Office2007Black.ini"
TaskPanelGlobalSettings.VisualTheme = xtpTaskPanelThemeResource

I can ony see the "ResourceImages" Property - there is no "ResourceThemeImages" Property!
 
Back to Top
SuperMario View Drop Down
Admin Group
Admin Group
Avatar

Joined: 14 February 2004
Status: Offline
Points: 18052
Post Options Post Options   Thanks (0) Thanks(0)   Quote SuperMario Quote  Post ReplyReply Direct Link To This Post Posted: 27 June 2013 at 1:02pm
ResourceImages is correct, the name was changed after the help was written.

There is no 2003 dll, that theme is internal.  Have any pics?
Back to Top
Hawk78 View Drop Down
Groupie
Groupie


Joined: 20 November 2012
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hawk78 Quote  Post ReplyReply Direct Link To This Post Posted: 28 June 2013 at 3:54am
I use this for setting VisualTheme (no load of any dll before)
wndTaskPanel.VisualTheme = xtpTaskPanelThemeOffice2003
 
The same Exe looks on different systems:
 
 
Is the Office2003 Theme still included in Version 16.xxx of TaskPanel Component?
Is there any chance to keep the "blue design" of my "Windows7" Screenshot?
 
Back to Top
SuperMario View Drop Down
Admin Group
Admin Group
Avatar

Joined: 14 February 2004
Status: Offline
Points: 18052
Post Options Post Options   Thanks (1) Thanks(1)   Quote SuperMario Quote  Post ReplyReply Direct Link To This Post Posted: 28 June 2013 at 11:52am
Its because it uses system colors.

Try setting this:

TaskPanelGlobalSettings.ColorManager.SystemTheme = xtpSystemThemeBlue 
wndTaskPanel.VisualTheme = xtpTaskPanelThemeOffice2003
Back to Top
Hawk78 View Drop Down
Groupie
Groupie


Joined: 20 November 2012
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hawk78 Quote  Post ReplyReply Direct Link To This Post Posted: 01 July 2013 at 2:34am
Hi Mario!
Perfect! Setting the Global Settings was the solution!
 
I tried to do the same for the Report Control. But there seems to be different problem. I loaded icons from ressoucefile for each record and for the watermark. The same Programm looks on different systems:
 
 
Here's my code:
 
    Dim P As IPictureDisp, ax as integer
    For ax = 1 To 4                                                                     
        Set P = LoadResPicture(500 + ax, vbResBitmap)                        ' Loading Ressource 501 to 504
        FrmPanWatchdog.WndReportControl.Icons.AddBitmap P.Handle, ax, xtpImageNormal, True
    Next

 
When I change my code and load the bitmap directly, there's no problem:
 
 FrmPanWatchdog.WndReportControl.Icons.LoadBitmap App.Path + "\1.bmp", ax, xtpImageNormal
 
Do you have an idea on this?
Back to Top
ABuenger View Drop Down
Newbie
Newbie
Avatar

Joined: 02 February 2006
Status: Offline
Points: 1075
Post Options Post Options   Thanks (0) Thanks(0)   Quote ABuenger Quote  Post ReplyReply Direct Link To This Post Posted: 01 August 2013 at 1:04pm
Hi, are you remote on the Windows 2003 server?

Watermark doesn't work with Remote Desktop etc.

Codejock support
Back to Top
Hawk78 View Drop Down
Groupie
Groupie


Joined: 20 November 2012
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hawk78 Quote  Post ReplyReply Direct Link To This Post Posted: 04 August 2013 at 12:26pm

Hi,

yes i'm by remote on Windows 2003. Is this a bug? I'm wondering because the icons are missing as well...

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.094 seconds.