Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > Visual C++ MFC > Report Control
  New Posts New Posts RSS Feed - BUG: Inplace ComboBox Button drawing - Office2007
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

BUG: Inplace ComboBox Button drawing - Office2007

 Post Reply Post Reply
Author
Message
Marco1 View Drop Down
Senior Member
Senior Member


Joined: 16 January 2004
Location: Germany
Status: Offline
Points: 251
Post Options Post Options   Thanks (0) Thanks(0)   Quote Marco1 Quote  Post ReplyReply Direct Link To This Post Topic: BUG: Inplace ComboBox Button drawing - Office2007
    Posted: 21 September 2010 at 9:59am
Im using an inplace ComboBox button for a date picker in a report control. Theme is Office2007 blue.

Item is constructed via something like:
pCol = m_wndReport.AddColumn(new CXTPReportColumn(...));
pCol->GetEditOptions()->m_bAllowEdit = TRUE;
pCol->GetEditOptions()->AddComboButton(TRUE);  // inplace button inside the cell

Now there seems to be an issue with the button itself: it is transparent, no solid fill, just the blue arrow is painted.
And the text gets shifted left it the cell is too small, but a fragment stayes left of the button (upper red arrow points to it).

See the picture:


CJ, is this known?

Can be verified in your ReportDemo also, but there it uses another theme which fills the button.
Testet with MfC 13.4.0.

Product: XTP 18.3.0 on VS 2017
Platform: VS 2017 / Windows 10 (64bit)
Back to Top
Marco1 View Drop Down
Senior Member
Senior Member


Joined: 16 January 2004
Location: Germany
Status: Offline
Points: 251
Post Options Post Options   Thanks (0) Thanks(0)   Quote Marco1 Quote  Post ReplyReply Direct Link To This Post Posted: 21 September 2010 at 12:25pm
The transparency of the button is fixed in MfC 13.4.1, but the fragment at the left side is still there!
Try with your demo to fix.

Product: XTP 18.3.0 on VS 2017
Platform: VS 2017 / Windows 10 (64bit)
Back to Top
Marco1 View Drop Down
Senior Member
Senior Member


Joined: 16 January 2004
Location: Germany
Status: Offline
Points: 251
Post Options Post Options   Thanks (0) Thanks(0)   Quote Marco1 Quote  Post ReplyReply Direct Link To This Post Posted: 16 October 2010 at 6:40pm
Just hoped you solved the problem, but in 13.4.2 - it's still there. Thumbs Down
Product: XTP 18.3.0 on VS 2017
Platform: VS 2017 / Windows 10 (64bit)
Back to Top
Marco1 View Drop Down
Senior Member
Senior Member


Joined: 16 January 2004
Location: Germany
Status: Offline
Points: 251
Post Options Post Options   Thanks (0) Thanks(0)   Quote Marco1 Quote  Post ReplyReply Direct Link To This Post Posted: 01 February 2019 at 10:12am
There is still a problem with the ReportControl inplace combobox in 18.6.0.
Problem is visible when the column is right aligned, using the xtpReportColumnResource/Office2010 theme.
The column is initialized with:

pCol->SetAlignment(xtpColumnTextRight);
pCol->GetEditOptions()->m_bAllowEdit = TRUE;
pCol->GetEditOptions()->m_bConstraintEdit = TRUE;
pCol->GetEditOptions()->AddComboButton(TRUE);
pCol->GetEditOptions()->AddConstraint("0.0%", 1);

Now clicking on the item shows:
The text goes a little to the left, that is fine.
But the inplace button is not visible and is overwritten with the text.
Clicking on the button position to open the combo gives:

The text is overwritten by the button.

1. CJ, can you provide a quick fix for that?
2. Is it possible to right align the combo text, too? According to the column alignment.




Product: XTP 18.3.0 on VS 2017
Platform: VS 2017 / Windows 10 (64bit)
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.094 seconds.