Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > Visual C++ MFC > Toolkit Pro
  New Posts New Posts RSS Feed - Issue with editing CXTPReportColumn text
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Issue with editing CXTPReportColumn text

 Post Reply Post Reply
Author
Message
vara2604 View Drop Down
Newbie
Newbie


Joined: 17 March 2022
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote vara2604 Quote  Post ReplyReply Direct Link To This Post Topic: Issue with editing CXTPReportColumn text
    Posted: 17 March 2022 at 4:59am
We have recently integrated our codebase with Xtreme ToolkitPro v20.2.0 version and found the breakage issue with editing text in CXTPReportColumn.

Issue can be easily reproducible with the ReportControl samples shipped with "Xtreme ToolkitPro v20.2.0" installation.

  1. Build below sample using 'Unicode Debug' or 'Unicode Release' configurations and launch the sample. 

    C:\Program Files (x86)\Codejock Software\MFC\Xtreme ToolkitPro v20.2.0\Samples\ReportControl\ReportAddRecordEx\ReportAddRecordEx_vc140.vcxproj


  2. Type some text in edit controls and try to edit the text now. Text disappears and shows the blank value. 
Note that this issue is not reproducible with the older version C:\Program Files (x86)\Codejock Software\MFC\Xtreme ToolkitPro v18.4.0.

We use CXTPReportColumn control multiple places and issue is seen in this all places. Could you please fix this ASAP?
Back to Top
Fredrik View Drop Down
Senior Member
Senior Member


Joined: 22 June 2005
Status: Offline
Points: 209
Post Options Post Options   Thanks (0) Thanks(0)   Quote Fredrik Quote  Post ReplyReply Direct Link To This Post Posted: 20 March 2022 at 11:23am
I reported this issue earlier and I believe it is already fixed for the next release. The workaround I have at the moment is to loop over all columns and call SetMask to initialize members that weren't initialized.


   for (int iColumn = 0; iColumn < GetColumns()->GetCount(); ++iColumn)
   {
      GetColumns()->Find(iColumn)->SetMask(L"", L"", '\0');
   }


Or add the hotfix in the XTP code:


void CXTPReportColumn::_initData(int nItemIndex, LPCTSTR strDisplayName, LPCTSTR strInternalName,
int nWidth, BOOL bAutoSize, int nIconID, BOOL bSortable,
BOOL bVisible)
{
...
m_chPrompt = _T('\0');
m_bUseMask = FALSE;
...

Windows 10, Visual Studio 20157, Toolkit Pro 18.3.0
Back to Top
kgi_Jony View Drop Down
Newbie
Newbie


Joined: 31 May 2022
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote kgi_Jony Quote  Post ReplyReply Direct Link To This Post Posted: 31 May 2022 at 10:15pm
hi

I met this problem too on the Xtreme ToolkitPro v20.0.0.

But I can't found the member function: SetMask() in class CXTPReportColumn.
Could you have more detail or sample code for me?

Thank you
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.059 seconds.