Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > Visual C++ MFC > Command Bars
  New Posts New Posts RSS Feed - ExpandButtonsAlways Problem
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

ExpandButtonsAlways Problem

 Post Reply Post Reply
Author
Message
Kenneth View Drop Down
Senior Member
Senior Member
Avatar

Joined: 23 May 2004
Location: United States
Status: Offline
Points: 256
Post Options Post Options   Thanks (0) Thanks(0)   Quote Kenneth Quote  Post ReplyReply Direct Link To This Post Topic: ExpandButtonsAlways Problem
    Posted: 05 August 2004 at 11:53am

In Xtreme Toolkit Pro, versions 9000 and 9100, if you set bShowExpandButtonsAlways=FALSE, the command barswill not align to the application right border correctly.  This can be seen by adding:

 GetCommandBars()->GetCommandBarsOptions()->bShow ExpandButtonAlways = FALSE;

in the Mainfrm.cpp, OnCreate function in the CommonControls sample.  There are four command bars in this sample, and all have the problem except for the on commandbar that has three radio buttons.

In addition to not aligning correctly to the application right border, they will also leave a gap between two adjoining commandbars on the same row.

 

Back to Top
Oleg View Drop Down
Admin Group
Admin Group


Joined: 21 May 2003
Location: United States
Status: Offline
Points: 11234
Post Options Post Options   Thanks (0) Thanks(0)   Quote Oleg Quote  Post ReplyReply Direct Link To This Post Posted: 10 August 2004 at 5:31am

Was bug with Toolbars with single buttons.

To fix in CXTPToolBar::CalcDockingLayout replace

if (dwMode & LM_HORZDOCK)
      sz.cx = max(sz.cx, szMin.cx + 11); else
      sz.cy = max(sz.cy, szMin.cy + 11);

to

    if (m_pControls->GetVisibleCount() > 1)
    {    
     if (dwMode & LM_HORZDOCK)
      sz.cx = max(sz.cx, szMin.cx + 11); else
      sz.cy = max(sz.cy, szMin.cy + 11);
    }

 

 

Oleg, Support Team
CODEJOCK SOFTWARE SOLUTIONS
Back to Top
Kenneth View Drop Down
Senior Member
Senior Member
Avatar

Joined: 23 May 2004
Location: United States
Status: Offline
Points: 256
Post Options Post Options   Thanks (0) Thanks(0)   Quote Kenneth Quote  Post ReplyReply Direct Link To This Post Posted: 11 August 2004 at 7:57pm
That fixed it.  Many thanks for this and the XTColorDialog fix.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.063 seconds.