Print Page | Close Window

[SOLVED]Translations not complete

Printed From: Codejock Forums
Category: Codejock Products
Forum Name: Toolkit Pro
Forum Description: Topics Related to Codejock Toolkit Pro
URL: http://forum.codejock.com/forum_posts.asp?TID=23974
Printed Date: 02 July 2020 at 7:11pm


Topic: [SOLVED]Translations not complete
Posted By: rdhd
Subject: [SOLVED]Translations not complete
Date Posted: 15 April 2020 at 10:04am
We have 19.0 and have found that some languages are not fully translated. I pulled 19.1 today and I see the same issue. See, for example, ToolkitPro.ResourcEs.(xml/dll). Note file new and a lot of other common commands have English strings in them. Search the xml file for 57600 to see "Create a new document\nNew". Some of the languages are fully translated while others are not. We could use a fix for this asap.

Here is a sample from the Spanish xml file:

    <string id="35229" value="Esloveno"/>
    <string id="35230" value="Español (España - Alfabetización internacional)"/>
    <string id="35231" value="Sueco"/>
    <string id="35232" value="Tailandés"/>
    <string id="35234" value="Ucraniano"/>
    <string id="57347" value="%1 in %2"/>
    <string id="57349" value="%1 - %2"/>
    <string id="57600" value="Create a new document\nNew"/>
    <string id="57601" value="Open an existing document\nOpen"/>
    <string id="57602" value="Close the active document\nClose"/>
    <string id="57603" value="Save the active document\nSave"/>
    <string id="57604" value="Save the active document with a new name\nSave As"/>
    <string id="57605" value="Change the printing options\nPage Setup"/>
    <string id="57606" value="Change the printer and printing options\nPrint Setup"/>
    <string id="57607" value="Print the active document\nPrint"/>
    <string id="57609" value="Display full pages\nPrint Preview"/>
    <string id="57612" value="Send the active document through e-mail\nSend Mail"/>
    <string id="57616" value="Open this document"/>
    <string id="57617" value="Open this document"/>
    <string id="57618" value="Open this document"/>





Replies:
Posted By: rdhd
Date Posted: 15 April 2020 at 3:01pm
I have compared CJ 18 to 19 and found that all the standard MFC command IDs have been added to the translation files. That is, they are not in 18. Hence, why this issue is now showing up with the 19 as, e.g., the Spanish file has nothing but English for these entries.

This makes me feel uncomfortable as the CJ translations don't always match up with our translations. Unfortunately we found long ago we had to deliver the CJ translations as CJ UI is part of a CJ based application so we have to use these files as we don't try to keep up with all string IDs CJ may use at some time for its own UI.

Tough issue though. We set the AFX res handle but CJ only uses it if a string isn't first found by its resource manager's res handle (or xml file). We don't use command IDs in the "9000" range (CJ IDs mostly use those) but one cannot always prevent some string ID not of a command to have such a value in our res file we set in the AFX module data.


Posted By: agontarenko
Date Posted: 30 April 2020 at 4:45am
Hello,

I have fixed this problem. Fix will be in 19.2 release.

Regards,
Artem Gontarenko


Posted By: rdhd
Date Posted: 30 April 2020 at 8:39am
Thanks Artem.



Print Page | Close Window