Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > ActiveX COM > Skin Framework
  New Posts New Posts RSS Feed - Form Blanking Out
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Form Blanking Out

 Post Reply Post Reply
Author
Message
shagge22 View Drop Down
Newbie
Newbie
Avatar

Joined: 21 November 2006
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote shagge22 Quote  Post ReplyReply Direct Link To This Post Topic: Form Blanking Out
    Posted: 24 January 2007 at 12:36pm
I am using Lead Tools v14 for one of my applications, along with the SkinFrameWork Control v10.3. I have the ability to place a annotation on the image, when I access the property window of the annotation the form is displaying blank. When I move the mouse over the form the controls appear and then disappear again. I have talked with Lead Tools and they have informed me that the forms are created with standard Microsoft forms and controls. I have also tried accessing the property window with out having the skin control present and it displays normal. I have attached a zip file containing two screen shots. Is there a property or setting that I am failing to set? Please help...

20070124_123432_AnnShot2.zip
Back to Top
Oleg View Drop Down
Admin Group
Admin Group
Avatar

Joined: 21 May 2003
Location: United States
Status: Offline
Points: 11234
Post Options Post Options   Thanks (0) Thanks(0)   Quote Oleg Quote  Post ReplyReply Direct Link To This Post Posted: 25 January 2007 at 1:26am
Hi,
Can you download and check 10.4.1 release.
Think it can be fixed already.
Oleg, Support Team
CODEJOCK SOFTWARE SOLUTIONS
Back to Top
shagge22 View Drop Down
Newbie
Newbie
Avatar

Joined: 21 November 2006
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote shagge22 Quote  Post ReplyReply Direct Link To This Post Posted: 22 February 2007 at 12:54pm
Sorry for the delay. I download v10.4.2 and placed the skin control into an example LeadTools Vb6 application. I placed the annotation on the image and then right clicked to access the properties window. The form comes up with only the tab control showing and the controls in the tab are not appearing still, but if I go to another tab option the controls appear correctly and if a go to other tabs, they too are showing. So it looks like it has been some what fixed. Here are two screen shots.

Does the skin control perform any sub-classing of common window classes?

20070222_125059_AnnShot.zip

My company would allow me to purchase another license for 10.4.2, but only if this bug can be fixed.

Regards...
Back to Top
Oleg View Drop Down
Admin Group
Admin Group
Avatar

Joined: 21 May 2003
Location: United States
Status: Offline
Points: 11234
Post Options Post Options   Thanks (0) Thanks(0)   Quote Oleg Quote  Post ReplyReply Direct Link To This Post Posted: 25 February 2007 at 1:08am
Hello,
Afraid now you have send complains to leadtools.
I didn't use SkiNFramework, but tried to add maniifest to use standard winXp themes:
 
I see same:
 
 
I sure it have to be fixed on leadtools code, strange that nobody from leadtools' customers never complains that library can't work with manifest enabled.
Oleg, Support Team
CODEJOCK SOFTWARE SOLUTIONS
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.