Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > Visual C++ MFC > Command Bars
  New Posts New Posts RSS Feed - Crash while password manager is active
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Crash while password manager is active

 Post Reply Post Reply
Author
Message
Harm Bakker View Drop Down
Groupie
Groupie
Avatar

Joined: 17 June 2008
Location: Netherlands
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote Harm Bakker Quote  Post ReplyReply Direct Link To This Post Topic: Crash while password manager is active
    Posted: 19 October 2018 at 11:48am
We are using XTToolkit version 18.5, and encounter regular crashes in our application.
We have already found out that these crashes happen when users have a password manager (such as StickyPassword) installed and activated.
The crash then occurs when one of our application windows is closed, and the call stack then always contains something like:

So, the UIAutomationCore seems to be involved, which is a part of the Windows UI Automation service. Apparently, StickyPassword uses this service to access UI elements in other applications.
Is this a 'known' problem for the XTToolkit, and how might we circumvent this?
Or does the XTToolkit need a fix to be able to live side by side with UI Automation like tools?

Kind regards, Harm Bakker
Back to Top
markr View Drop Down
Senior Member
Senior Member


Joined: 01 August 2004
Status: Offline
Points: 397
Post Options Post Options   Thanks (0) Thanks(0)   Quote markr Quote  Post ReplyReply Direct Link To This Post Posted: 28 January 2019 at 10:50pm
Were you able to figure anything out on this? We're seeing crashes that appear to be related to uiautomationcore.dll as well.

- Mark
Back to Top
fleg View Drop Down
Groupie
Groupie


Joined: 11 July 2012
Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote fleg Quote  Post ReplyReply Direct Link To This Post Posted: 29 January 2019 at 4:27am
Hi,
This makes me think about issue we had on startup. Application does not crash but is frozen when loading. Happens when 3rd party application are installed on the machine, typically like password manager or fingerprint reader.
Fortunately, this was magically fixed when upgrading toolkitpro from 18.4 to 18.6
Maybe not the same issue as yours, but might worth to test with XTP 18.6

Fabien
Back to Top
agontarenko View Drop Down
Admin Group
Admin Group


Joined: 25 March 2016
Status: Offline
Points: 116
Post Options Post Options   Thanks (0) Thanks(0)   Quote agontarenko Quote  Post ReplyReply Direct Link To This Post Posted: 06 February 2019 at 2:07am
Hello,

This problem occurs during using SkinFramework?
If yes use ExcludeModule("XXX.DLL")

Regards,
Artem Gontarenko
Back to Top
markr View Drop Down
Senior Member
Senior Member


Joined: 01 August 2004
Status: Offline
Points: 397
Post Options Post Options   Thanks (0) Thanks(0)   Quote markr Quote  Post ReplyReply Direct Link To This Post Posted: 25 February 2019 at 5:16pm
Hello,

> This problem occurs during using SkinFramework?

My application does not use CJ SkinFramework.

Regards,

Mark R.
Back to Top
astoyan View Drop Down
Admin Group
Admin Group
Avatar

Joined: 24 August 2013
Status: Offline
Points: 188
Post Options Post Options   Thanks (0) Thanks(0)   Quote astoyan Quote  Post ReplyReply Direct Link To This Post Posted: 25 February 2019 at 6:35pm
There is no any visible evidence that it is caused by ToolkitPro at all. The initial screen shot does not have any ToolkitPro stack trace entry. ToolkitPro cannot be responsible for whatever some password manager is doing in a scope of a process it is injected into. It still may be some subtle conflict that all or some involved parties can be responsible for, but it is not sufficient information provided to make any such conclusion.

I can only suggest the following:
 1. Start disabling/removing a pieces of code until you have an absolutely bare minimum of the code necessary for a crash to be reproducible
 2. Look for any apparent evidences that it is caused by ToolkitPro either directly or indirectly
 3. Try to eliminate any possible conflicts with 3rd-party components or side-effects
 4. Open a new support ticket with all your finding including the test project uploaded, provide detailed description of the system and development environment configuration

Thank you
Alexander
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.