Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > ActiveX COM > Controls
  New Posts New Posts RSS Feed - Issue with popup control
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Issue with popup control

 Post Reply Post Reply
Author
Message
Carpesimia View Drop Down
Groupie
Groupie
Avatar

Joined: 15 February 2010
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote Carpesimia Quote  Post ReplyReply Direct Link To This Post Topic: Issue with popup control
    Posted: 13 March 2018 at 11:39am
Ok, so this time I do really have an issue, so here it is.

Again, using the activex version of the controls, and I'm using the popup control when someone accesses a certain part of the system.

The popups appear fine, but when someone clicks the hyperlink, its not firing the itemclick event as it should.

It works fine in the VB IDE when I'm running the program, but when I compile to an exe it is not.  The popups come up fine, with the correct information, but the click event for the link on the popup is not working.

Im setting the item.hyperlink = true
and item.id = IDLICENSEWIZ

When running in the IDE, clicking the line with the item.hyperlink=true causes the popupctl_itemclick event to fire, where I then check the ID to see what it matches.  I put a msgbox in that sub, and the code is not even getting into that location when compiled to an exe.

Ideas?

Product: Xtreme SuitePro (ActiveX) version 13.2.1
Platform: Windows XP (32bit) - SP 2
Language: Visual Basic 6.0
Back to Top
Carpesimia View Drop Down
Groupie
Groupie
Avatar

Joined: 15 February 2010
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote Carpesimia Quote  Post ReplyReply Direct Link To This Post Posted: 13 March 2018 at 12:19pm
Ok so a little more testing tells me a few things:

1) This is only the itemclick event that's not firing.  The stateChanged event fires fine.

2) The SAMPLE app works fine.  Of course.

Could really use some assistance on this.  These popups were a control I didnt even know I had, and I finally implement them, and it doesnt work when compiled code.
Product: Xtreme SuitePro (ActiveX) version 13.2.1
Platform: Windows XP (32bit) - SP 2
Language: Visual Basic 6.0
Back to Top
Carpesimia View Drop Down
Groupie
Groupie
Avatar

Joined: 15 February 2010
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote Carpesimia Quote  Post ReplyReply Direct Link To This Post Posted: 13 March 2018 at 12:29pm
And a little more info...

So I closed EVERYTHING else that is running on the machine.  When the popups appear, and I mouse over them, the cursor does change.  So windows does recognize something is there.  A click or even a right click dont do anything.  If it was the desktop, it would show me the right-click context menu.

So, the popup is there.  It's just not firing the itemclick event.
Product: Xtreme SuitePro (ActiveX) version 13.2.1
Platform: Windows XP (32bit) - SP 2
Language: Visual Basic 6.0
Back to Top
Carpesimia View Drop Down
Groupie
Groupie
Avatar

Joined: 15 February 2010
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote Carpesimia Quote  Post ReplyReply Direct Link To This Post Posted: 16 March 2018 at 8:48pm
And MORE information...


So.. my actual controls on pages all work.  But the popup control doesnt fire any event except for the state_changed event.

So I just spent awhile getting my head wrapped around how the markup code works, and got that working in the IDE.

Once again, that doesnt work EITHER when compiled.

I have a valid license.

I have the license info for both skinframework (whole app is skinned, and that works fine) and for the suitecontrols both in the form.initialize() of the startup form.

I even changed the registration code from my original "Skinframeworkglobalsettings.license" to the suggested "dim skinSettings as new skinframeworkglobalsettings" method that some people have claimed needs to work.  Yeah, I was assuming this issue was related to licensing.

Still nothing.

Ive wasted literally days trying to get this code working.

Product: Xtreme SuitePro (ActiveX) version 13.2.1
Platform: Windows XP (32bit) - SP 2
Language: Visual Basic 6.0
Back to Top
Carpesimia View Drop Down
Groupie
Groupie
Avatar

Joined: 15 February 2010
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote Carpesimia Quote  Post ReplyReply Direct Link To This Post Posted: 16 March 2018 at 8:51pm
I even stuck the licensing code on the actual form that has the popups on it.  Still nada.

Guess Ill mess with the state changed and see if I can get something out of that.


Product: Xtreme SuitePro (ActiveX) version 13.2.1
Platform: Windows XP (32bit) - SP 2
Language: Visual Basic 6.0
Back to Top
Carpesimia View Drop Down
Groupie
Groupie
Avatar

Joined: 15 February 2010
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote Carpesimia Quote  Post ReplyReply Direct Link To This Post Posted: 17 March 2018 at 6:25pm
Well, I figured it out.  

Since noone responded to my questions, I created my own pretty cool popup class to create my own popups, and it worked pretty good in my test project.  But as soon as I brought it into my main project and added the code, it immediately started behaving the same way as the codejock controls.  My popup notifications slid into view, but then would not recognize any of the click events.

So back to work I went, debugging.

Somewhere along the way, I had a thought that my problem might be that i was in the form_load event, and the form loading (called modally) may not be considered modal until the form_load finished.  If it became "modal" (i.e, not allowing any other forms be accessed) after the form_load event, it could keep me from clicking my popup forms.   So I added a timer, and set it to 1 second, and then added my popup code when the timer fired.

Then my popups didnt show at all.

So, I started ripping the code apart and simplifying it to find out what the problem was.  And I found it.  I made my popups using a form that I stylized into a nice popup window.  Seems that when you try to load a non-modal form FROM a modal form, it errors out.  But, if you do it programmatically, it might not.  Intestingly enough, my forms WERE being created (I saw the debug.print messages as they drew themselves, and moved themselves around for my slide-effect), they just werent visible.  Bastages.

So my thought was EXACTLY correct.  If you load something (like a form) in the form_load event, the loading form doesnt become "modal" until the form_load is complete.

With this in mind, I put the code for the codejock popups back into play, to be called from the timer after the form load event finishes.

And yes, it works now.  Compiled it to an exe and the itemclick events now work.  So it was the form_load drawing the popups before making the form modal.  They drew, but could not be clicked.

All these years I've been coding in VB, and I still learn something new.

Hope this hopes anyone else having the same problem, since codejock doesnt seem interested in responding.
Product: Xtreme SuitePro (ActiveX) version 13.2.1
Platform: Windows XP (32bit) - SP 2
Language: Visual Basic 6.0
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.094 seconds.