Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > Visual C++ MFC > Toolkit Pro
  New Posts New Posts RSS Feed - VS2017 and 18.3: XTP_DISABLE_ADVANCED_WARNINGS
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

VS2017 and 18.3: XTP_DISABLE_ADVANCED_WARNINGS

 Post Reply Post Reply
Author
Message
renninha View Drop Down
Groupie
Groupie


Joined: 10 August 2007
Location: Sweden
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote renninha Quote  Post ReplyReply Direct Link To This Post Topic: VS2017 and 18.3: XTP_DISABLE_ADVANCED_WARNINGS
    Posted: 23 February 2018 at 7:59am
When I try to compile my program in VS2017 and version 18.3 I get this error message:
Error C1189
#error:  XTP_DISABLE_ADVANCED_WARNINGS must not be defined twice. The state of advanced warnings must be restored.
c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.3.0\source\common\base\diagnostic\xtpenableadvancedwarnings.h 160

I didn't get this when compiling with 18.3 in VS2013, but I'm new to VS2017 - maybe it's some parameter there to change...
Tried to compare to the ribbon sample, but I can't find any important differences.
Please help...

Thanks,

Back to Top
renninha View Drop Down
Groupie
Groupie


Joined: 10 August 2007
Location: Sweden
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote renninha Quote  Post ReplyReply Direct Link To This Post Posted: 23 February 2018 at 8:19am
Think I found it... my error...
Back to Top
Sven View Drop Down
Senior Member
Senior Member


Joined: 21 August 2003
Location: Germany
Status: Offline
Points: 125
Post Options Post Options   Thanks (0) Thanks(0)   Quote Sven Quote  Post ReplyReply Direct Link To This Post Posted: 06 March 2018 at 4:31am
I'm getting the same errors after changing the toolset from 2013 to 2017. What did you do?
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.125 seconds.