Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > ActiveX COM > Chart Control
  New Posts New Posts RSS Feed - Axis labels missing
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Axis labels missing

 Post Reply Post Reply
Author
Message
iliketurtles View Drop Down
Newbie
Newbie


Joined: 25 January 2017
Status: Offline
Points: 8
Post Options Post Options   Thanks (0) Thanks(0)   Quote iliketurtles Quote  Post ReplyReply Direct Link To This Post Topic: Axis labels missing
    Posted: 07 September 2017 at 11:53am
I have a chart that shows currency values over time with X and Y axes labelled. One of my users reports that the labels are missing. I verified that the  titles appear, but not the axis labels. I don't see any reason why they would be missing for only one user. Any ideas? Using version 16.4.0.

Here is the relevant label setup code:

    Dim Diagram As ChartDiagram2D
    Set Diagram = Me.chart.Content.Series(0).Diagram
    Diagram.AxisY.Title = "Value"
    Diagram.AxisY.Title.Visible = True
    Diagram.AxisY.label.Format.Category = xtpChartCurrency
    Diagram.AxisY.label.Format.DecimalPlaces = 0
    Diagram.AxisY.label.Format.UseThousandSeparator = True

    Diagram.AxisX.Title = "Date"
    Diagram.AxisX.Title.Visible = True
    Diagram.AxisX.label.Format.DateTimeCategory = xtpChartDateTimeCustom
    Diagram.AxisX.label.Format.DateTimeFormat = "MM/dd/yyyy"
    Diagram.AxisX.label.Angle = 315
    Diagram.AxisX.DateTimeScaleUnit = xtpChartScaleMonth
   
    Diagram.AllowZoom = True
    Diagram.AllowScroll = True
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.105 seconds.