Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > ActiveX COM > Controls
  New Posts New Posts RSS Feed - [SOLVED]DPI-Awareness of the tree control
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

[SOLVED]DPI-Awareness of the tree control

 Post Reply Post Reply
Author
Message
Alex H. View Drop Down
Senior Member
Senior Member
Avatar

Joined: 12 February 2004
Status: Offline
Points: 239
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alex H. Quote  Post ReplyReply Direct Link To This Post Topic: [SOLVED]DPI-Awareness of the tree control
    Posted: 14 November 2016 at 8:26am
Hi Codejock-Team and community members!

We use XTP 17.3 and have problems with the tree control.

When changing Monitor dpi-value to 150%:
The icons are ok, because we only have 16*16 size icons but the text is cut.


As you can see these german words are not displayed in full:
Belege
Projekte
Sonstige

I think there is something missing when calculating the size of the text.

Can you send us a patch for that?

:-)


Back to Top
agontarenko View Drop Down
Admin Group
Admin Group


Joined: 25 March 2016
Status: Offline
Points: 73
Post Options Post Options   Thanks (1) Thanks(1)   Quote agontarenko Quote  Post ReplyReply Direct Link To This Post Posted: 16 November 2016 at 5:45am
Hello Alex,

Do you have same problem with v17.2?
Please, provide steps for reproduce it with our samples.

Regards,
 Artem Gontarenko
Back to Top
Alex H. View Drop Down
Senior Member
Senior Member
Avatar

Joined: 12 February 2004
Status: Offline
Points: 239
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alex H. Quote  Post ReplyReply Direct Link To This Post Posted: 17 November 2016 at 4:33am


XTP 17.2 ssems to center icon and text which is also better

Back to Top
Alex H. View Drop Down
Senior Member
Senior Member
Avatar

Joined: 12 February 2004
Status: Offline
Points: 239
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alex H. Quote  Post ReplyReply Direct Link To This Post Posted: 17 November 2016 at 4:49am
Problem solved!

Sorry it was our fault:   We had an explicit SetItemHeigh for that tree.

Thank you Artem!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.094 seconds.