Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > ActiveX COM > Controls
  New Posts New Posts RSS Feed - Add AxImageManager icons to AxListview fails v17.0
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Add AxImageManager icons to AxListview fails v17.0

 Post Reply Post Reply
Author
Message
iamgtd View Drop Down
Senior Member
Senior Member
Avatar

Joined: 25 February 2009
Status: Offline
Points: 123
Post Options Post Options   Thanks (0) Thanks(0)   Quote iamgtd Quote  Post ReplyReply Direct Link To This Post Topic: Add AxImageManager icons to AxListview fails v17.0
    Posted: 26 January 2016 at 4:05am
In a C#-solution we use the AxImageManager to manage icons for the commandbar and also for controls like AxListView. The approach is that we first load the icons and bitmaps to the AxImageManager control. And then we add the icons from the AxImagemanager to the Icons property of the AxListview.

// Load icons, bitmaps
cjImageManager.Icons.LoadIcon(IconsPath() + "CjSample.ico", 1, XtremeCommandBars.XTPImageState.xtpImageNormal);
cjImageManager.Icons.LoadBitmap(IconsPath() + "AlphaFind.bmp", 2, XtremeCommandBars.XTPImageState.xtpImageNormal);

// Add icons to listview
cjListView.Icons = (XtremeSuiteControls.ImageManagerIcons)cjImageManager.Icons;


This worked with all previous Codejock versions. With Codejock version 17.0 the following error occurs:

System.ArgumentException: Der Wert liegt au├čerhalb des erwarteten Bereichs. (The value is outside the expected range.)
   bei System.RuntimeType.ForwardCallToInvokeMember(String memberName, BindingFlags flags, Object target, Int32[] aWrapperTypes, MessageData& msgData)
   bei XtremeSuiteControls._DListView.set_Icons(ImageManagerIcons )
   bei AxXtremeSuiteControls.AxListView.set_Icons(ImageManagerIcons value)
   bei TestCodeJockImageManager.Form1.Form1_Load(Object sender, EventArgs e) in C:\Projects\Testprojekte\TestCodeJockImageManager\TestCodeJockImageManager\Form1.cs:Zeile 25.

---------

OS: Win 7 64 bit

Codejock Version 17.2 ActiveX

MS Visual Studio 2010 - C# 2010 SP1

---------
Back to Top
rmeling View Drop Down
Newbie
Newbie
Avatar

Joined: 18 April 2007
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote rmeling Quote  Post ReplyReply Direct Link To This Post Posted: 13 October 2016 at 3:58am
Same problem here (this was ok until at least version 16.3.1). 

Same error with TreeView control. CommandBars control is working with ImageManager Icons

Any solutions for this problem?

Thx and best regards
Robin

CodeJock 17.2.0 ActiveX
Progress OpenEdge 11.3.3
Microsoft Windows Server 2012 R2
Back to Top
derekl View Drop Down
Groupie
Groupie


Joined: 23 October 2006
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote derekl Quote  Post ReplyReply Direct Link To This Post Posted: 29 November 2016 at 2:44pm
I have the same issue.
Seems to be with the 64 bit controls (ActiveX 17.2).

I reported it 5 days ago as a support issue but have still had no response from support.

Very frustrating.
Back to Top
astoyan View Drop Down
Admin Group
Admin Group
Avatar

Joined: 24 August 2013
Status: Offline
Points: 177
Post Options Post Options   Thanks (1) Thanks(1)   Quote astoyan Quote  Post ReplyReply Direct Link To This Post Posted: 05 December 2016 at 1:58am
Hello,

I'm glad to inform you the issue has been fixed for 18.0. Please wait for the update and once it's out please test the fix and let us know if anything doesn't work as expected.

Regards,
  Alexander
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.