Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > Visual C++ MFC > Syntax Edit
  New Posts New Posts RSS Feed - CXTPSyntaxEditCtrl and Korean Language
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

CXTPSyntaxEditCtrl and Korean Language

 Post Reply Post Reply
Author
Message
yeol238 View Drop Down
Newbie
Newbie


Joined: 28 November 2013
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote yeol238 Quote  Post ReplyReply Direct Link To This Post Topic: CXTPSyntaxEditCtrl and Korean Language
    Posted: 04 July 2014 at 1:07am
I'm using the CXTPSyntaxEditCtrl class on CDialog.

It can load a file in korean language without problem.

But when I try to enter korean character, it change to '?' like below picture. 



Do you have any idea to solve this problem?


SYLee
Back to Top
kstowell View Drop Down
Admin Group
Admin Group
Avatar

Joined: 25 January 2003
Location: MIchigan, USA
Status: Offline
Points: 494
Post Options Post Options   Thanks (0) Thanks(0)   Quote kstowell Quote  Post ReplyReply Direct Link To This Post Posted: 08 July 2014 at 4:05pm
Have you compiled your application and the SyntaxEditCtrl in UNICODE?
Kirk Stowell, President and CEO
CODEJOCK SOFTWARE SOLUTIONS
Back to Top
yeol238 View Drop Down
Newbie
Newbie


Joined: 28 November 2013
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote yeol238 Quote  Post ReplyReply Direct Link To This Post Posted: 10 July 2014 at 12:02am
Yes I did. It doesn't work. And I have to using multi-byte option.

Do you have any idea? 
Back to Top
astoyan View Drop Down
Admin Group
Admin Group
Avatar

Joined: 24 August 2013
Status: Offline
Points: 177
Post Options Post Options   Thanks (0) Thanks(0)   Quote astoyan Quote  Post ReplyReply Direct Link To This Post Posted: 16 July 2014 at 11:34pm
Hello SYLee,

Which version ot ToolkitPro are you using? And what is you OS?
We've tried CXTPSyntaxEditCtrl from the currently released version on a dialog and in many other scenarios with Korean and some other languages and didn't notice the behavior you experieced. But we tried Unicode version of the control, the Multi-byte one does not support any of the Unicode languages neither for loading nor for typing.

As for your test of the Unicode version, what input method di you use for the Korean language and how did you initialize the control?

Thank you.
Regards,
  Alexander Stoyan
Back to Top
yeol238 View Drop Down
Newbie
Newbie


Joined: 28 November 2013
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote yeol238 Quote  Post ReplyReply Direct Link To This Post Posted: 17 July 2014 at 2:26am
Xtreme ToolkitPro v16.3.1

Windows 8.1

I'm trying with Unicode option, but it doesn't work.
Back to Top
astoyan View Drop Down
Admin Group
Admin Group
Avatar

Joined: 24 August 2013
Status: Offline
Points: 177
Post Options Post Options   Thanks (0) Thanks(0)   Quote astoyan Quote  Post ReplyReply Direct Link To This Post Posted: 17 July 2014 at 10:02pm
Have you tried MDITextEditor sample application? If not, please try it out and let me know about results.
Back to Top
Norika View Drop Down
Groupie
Groupie
Avatar

Joined: 30 November 2006
Status: Offline
Points: 61
Post Options Post Options   Thanks (0) Thanks(0)   Quote Norika Quote  Post ReplyReply Direct Link To This Post Posted: 17 July 2014 at 11:29pm
Hi SYLee,

Did you already change the Font property of the Systax Edit control to be able to properly display Hangul the value like Meiryo UI or MS UI Gothic?
Back to Top
yeol238 View Drop Down
Newbie
Newbie


Joined: 28 November 2013
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote yeol238 Quote  Post ReplyReply Direct Link To This Post Posted: 18 July 2014 at 12:30am
I tried MDITextEditorView sample. It works well.

But it is based on CXTPSyntaxEditView. I want to use CXTPSyntaxEditCtrl on Dialog Window.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.