Codejock Forums Homepage
Forum Home Forum Home > Codejock Products > Visual C++ MFC > Skin Framework
  New Posts New Posts RSS Feed - Skin Builder not generating necessary ribbon entry
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Skin Builder not generating necessary ribbon entry

 Post Reply Post Reply
Author
Message
DukeOfVacation View Drop Down
Newbie
Newbie


Joined: 09 November 2012
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote DukeOfVacation Quote  Post ReplyReply Direct Link To This Post Topic: Skin Builder not generating necessary ribbon entry
    Posted: 09 November 2012 at 11:40am
Hi, I'm experimenting with building a custom skin for a project at work. However, Skin Builder doesn't seem to be generating entries in the .rc file for ribbon bitmaps.

I'm starting with a base Office2007 theme when creating a new style... but when I export it seems to be missing these that are found in the "Source\Styles\Office2007\Office2007.rc":

OFFICE2007BLUE_RIBBONGROUPQUICKACCESS_BMP   PNG  MOVEABLE PURE "Styles\\Office2007\\res\\Blue_RibbonGroupQuickAccess.png"
OFFICE2007BLUE_RIBBONQUICKACCESSFRAME_BMP   PNG  MOVEABLE PURE "Styles\\Office2007\\res\\Blue_RibbonQuickAccessFrame.png"
OFFICE2007BLUE_RIBBONQUICKACCESSAREA_BMP   PNG  MOVEABLE PURE "Styles\\Office2007\\res\\Blue_RibbonQuickAccessArea.png"
OFFICE2007BLUE_FRAMECAPTIONMAXIMIZE13_BMP   PNG  MOVEABLE PURE "Styles\\Office2007\\res\\Blue_FrameCaptionMaximize13.png"

What ends up happening is our program tries to find these resources but they don't exist in the new .RC file that I've generated from skin Builder and it fails.

Am I doing something incorrect? or is there a different method that I need to approach when skinning the ribbon?

Thanks,
Duke
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.063 seconds.